Ошибка импортирования OVF в VMware vCLoud Director

Ошибка импортирования OVF в VMware vCLoud Director

vmware logoДобрый день! Уважаемые читатели и гости популярного компьютерного блога pyatilistnik.org. В прошлый раз мы с вами решили ошибку: "virtual machine disks consolidation is needed", на одной из виртуальных машин, сегодня продолжим наш траблшутинг. Я вам много уже рассказывал про облачные сервисы, где вы можете размещать свои ресурсы, и одним из таких является программный продукт VMware vCLoud Director, на базе которого многие Цоды, строят свои облака. Есть компания Dataline, которая предоставляет облачный сервис, в момент импортирования в него OVF шаблона с файлами виртуальной машины, я получил ошибку: "The OVF package requires hardware version 13 but the selected VDC only supports hardware version 11". Ниже я вам покажу, как решается данная проблема.

Вот так вот выглядит ошибка при импортировании ее в vApp, на шаге "Select Name and Location"

The OVF package requires hardware version 13

Из скриншота видно, что проблема при добавлении OVF шаблона, заключается в том, что сервер VMware vCLoud Director, недостаточно свежий и просто не настроен на поддержку свежих версий виртуальных машин.

Пути решения ошибки "The OVF package requires hardware version 13"

Тут два варианта решения данной ситуации:

  • Обновить поддержку оборудования на VMware vCLoud Director, это правильный вариант, но не всегда быстро выполним, так как у вас у самих нет управления над данной инфраструктурой.
  • Уменьшить версию виртуального оборудования виртуальной машины, делается за несколько минут, и при единичной задаче, подойдет, но все же нужно заставить провайдера облачных услуг произвести обновление на vCLoud Director.

Обновление поддержки новых Hardware version в vCLoud Director

Есть официальная KB у Vmware по этому поводу за номером 2073727

https://kb.vmware.com/s/article/2073727

В нем нам предлагается открыть административную консоль управления и перейти в пункт System - Manage & Monitor

Manage & Monitor VMware vCLoud Director

Далее пункт Provider VDCs - Properties. Найдите пункт "Highest supported hardware version" и выберите нужную вам версию виртуального оборудования.

Обновление поддержки свежего виртуального оборудования в VMware vCLoud Director

Как видите для провайдера облачных услуг, это не сложное телодвижение, проще чем вы будите уменьшать версию виртуального оборудования в конфигурационном файле. Теперь вы знаете как решить ошибку: "The OVF package requires hardware version 13 but the selected VDC only supports hardware version 11".

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *