Как сделать резервирование каналов интернет на Cisco 881 — оригинальное решение с vrf

Как сделать резервирование каналов интернет на Cisco 881 — оригинальное решение с vrf

Как сделать резервирование каналов интернет на Cisco 881 — оригинальное решение с vrf

Как сделать резервирование каналов интернет на Cisco 881 — оригинальное решение с vrf

Существует множество способов реализовать резервирование каналов подключения к Интернет с помощью роутера Cisco. В этой статье я хочу привести пример такого подключения, который обычно использую. Он очень простой и в то же время изящный и основан на технологии vrf lite.

Vrf lite разделяет наш цельный физический роутер на несколько логических. Каждый из каналов доступа в Интернет подключается к своему VRF. Оба VRF связаны общим OSPF процессом с основным роутером, передавая маршрут в Интернет по-умолчанию в зависимости от установленного приоритета. VRF являются полноценными роутерами, по этому для связи с основным роутером нужно использовать несколько loopback интерфейсов.

[wpspoiler name="Подробнее" ]

version 15.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
boot-start-marker
boot system flash:c880data-universalk9-mz.153-2.T.bin
boot-end-marker
!
no aaa new-model
memory-size iomem 10
!
ip vrf ISP
description ISP1
!
ip vrf ISP2
description ISP2
!
ip cef
no ipv6 cef
!
!
multilink bundle-name authenticated
!
crypto ipsec transform-set IPSEC esp-aes esp-sha-hmac
mode tunnel
!
bridge irb
!
interface Loopback11
description VRF ISP, OSPF
ip address 10.255.255.1 255.255.255.255
!
interface Loopback12
description VRF ISP, OSPF
ip address 10.255.255.2 255.255.255.255
!
interface Loopback21
description VRF ISP2, OSPF
ip address 10.255.255.3 255.255.255.255
!
interface Loopback22
description VRF ISP2, OSPF
ip address 10.255.255.4 255.255.255.255
!
interface Tunnel0
description VRF ISP, OSPF
ip address 10.255.254.1 255.255.255.252
ip ospf 10 area 0
tunnel source Loopback11
tunnel destination 10.255.255.2
!
interface Tunnel1
description VRF ISP, OSPF
ip vrf forwarding ISP
ip address 10.255.254.2 255.255.255.252
ip nat inside
ip virtual-reassembly in
ip ospf 1 area 0
tunnel source Loopback12
tunnel destination 10.255.255.1
!
interface Tunnel2
description VRF ISP2, OSPF
ip address 10.255.254.5 255.255.255.252
ip ospf 10 area 0
tunnel source Loopback21
tunnel destination 10.255.255.4
!
interface Tunnel3
description VRF ISP2, OSPF
ip vrf forwarding ISP2
ip address 10.255.254.6 255.255.255.252
ip nat inside
ip virtual-reassembly in
ip ospf 2 area 0
tunnel source Loopback22
tunnel destination 10.255.255.3
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
description ISP2
switchport access vlan 2
no ip address
!
interface FastEthernet4
ip vrf forwarding ISP
ip address 3.3.3.3 255.255.255.0
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip tcp adjust-mss 1340
!
interface Vlan2
ip vrf forwarding ISP2
ip address 4.4.4.4 255.255.255.0
ip nat outside
ip virtual-reassembly in
!
router ospf 1 vrf ISP
passive-interface default
no passive-interface Tunnel1
network 10.255.254.0 0.0.0.3 area 0
default-information originate metric 100 metric-type 1
!
router ospf 2 vrf ISP2
passive-interface default
no passive-interface Tunnel3
network 10.255.254.4 0.0.0.3 area 0
default-information originate metric 110 metric-type 1
!
router ospf 10
redistribute connected subnets
passive-interface default
no passive-interface Tunnel0
no passive-interface Tunnel2
network 10.255.254.0 0.0.0.3 area 0
network 10.255.254.4 0.0.0.3 area 0
!
ip dns view default
domain timeout 2
ip nat translation tcp-timeout 240
ip nat translation udp-timeout 10
ip nat service enable-sym-port
ip nat inside source list NAT interface FastEthernet4 vrf ISP overload
ip nat inside source list NAT interface vlan 2 vrf ISP2 overload
ip route vrf ISP 0.0.0.0 0.0.0.0 3.3.3.1
ip route vrf ISP2 0.0.0.0 0.0.0.0 4.4.4.1
!
ip access-list extended NAT
deny ip any 10.0.0.0 0.255.255.255
deny ip any 192.168.0.0 0.0.255.255
permit ip 10.0.0.0 0.255.255.255 any
permit ip 192.168.0.0 0.0.255.255 any
!
logging history size 20
no logging trap
!
end

[/wpspoiler]

Материал сайта Pyatilistnik.org

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

я в гугл