Как настроить сетевой интерфейс на маршрутизаторе juniper srx210

Как настроить сетевой интерфейс на маршрутизаторе juniper srx210

Как настроить сетевой интерфейс на маршрутизаторе juniper srx210

Добрый день уважаемые читатели блога, сегодня я хочу показать вам как настроить сетевой интерфейс на маршрутизаторе juniper srx210. В примере будут рассмотрены как графический метод, так и через командную строку, вы уже сами определите какой метод вам нравится больше.

Маршрутизатор juniper srx210

Давайте посмотрим как выглядит srx210. У него два гигабитных порта ge-0/0/0-1 и 6 100 мегабитных портов fe-0/0/2-7, а так же порт управления.

srx210

Для подключения в console порт, вам нужно будет подключить к компьютеру com порт-USB устройство, как это сделать смотрите по ссылке слева.

JunOS есть два основных режима командного интерфейса.
1. для исполнения команд, приглашение заканчивается на ">"
2. для изменения конфигурации, приглашение заканчивается на "#"

Есть еще sh, он заканчивается на "%", но в ближайшее время он нам не пригодится.

Если лень переключаться, из режима конфигурирования для исполнения какой-либо команды, можно добавить в начало команды run.

Далее логично, что нужно задать для вашего маршрутизатора статический локальный ip адрес, а потом еще и внешний, для организации например vpn туннелей Juniper. У нас на выбор три метода

Настроим Ip адрес в ручную

Переходим в режим конфигурирования

root@% cli
root@jun2-msk> configure
Entering configuration mode

В Juniper, как и в Cisco все ip адреса назначаются не на физические интерфейсы, а на логические. В командной строке есть вот такая команда.

  • set > говорим что будем задавать
  • interfaces ge-0/0/0 > на интерфейс ge-0/0/0
  • unit > то что будет логический интерфейс с номером 0
  • family inet > протокол ipv4
  • address > адрес с подсетью

set interfaces ge-0/0/0 unit 0 family inet address 192.168.6.5/24

Чтобы задать шлюз по умолчанию, то вводим

  • set routing-options static route > говорим что если мы идем по маршруту 0.0.0.0/0 используем next-hop
  • next-hop > шлюз

set routing-options static route 0.0.0.0/0 next-hop 10.152.1.1

Задать описание для интерфейса можно командой

set interfaces ge-0/0/0 unit 0 description local-interface

Посмотреть таблицу маршрутизации в Juniper можно командой

show route

Посмотреть таблицу маршрутизации в Juniper

Добавим его в зону trust

set security zones security-zone trust interfaces ge-0/0/0

Поменять ip адрес у интерфейса можно вот так, где мы меняем с 192.168.6.5/24 на 192.168.6.6/24

rename ge-0/0/0 unit 0 family inet address 192.168.6.5/24 to address 192.168.6.6/24

Сохраняем изменения командой Commit, если до этого ввести Commit check, то будет выполнена проверка конфигурации, и если что то будут не правильно вам об этом сообщат.

Настроим Ip адрес через web интерфейс

Настроить сетевой интерфейс на маршрутизаторе juniper srx210 можно и через графический интерфейс, но его сначала нужно включить. Выполним

set system services web-management http interface [ge-0/0/0]

Мы для порта ge-0/0/0 включили веб мордочку. Можно и для vlan, что такое vlan можно почитать по ссылке.

set system services web-management http interface vlan.0

не забываем сохранить конфигурацию командой Commit. Все открываем веб интерфейс и логинимся.

Как настроить сетевой интерфейс на маршрутизаторе juniper srx210-2

Идем в раздел Configure > Interfaces > Ports и видим, список всех портов и среди них наш гигабитный ge-0/0/0. Чтобы посмотреть его настройки выберите его и нажмите Edit.

Как настроить сетевой интерфейс на маршрутизаторе juniper srx210-3

В настройках логического интерфейса вы можете поменять описание и IP адрес, при желании можете включить получение его через DHCP.

маршрутизатор juniper srx210-1

Если вы что то поменяли в настройках, srx это проверит и покажет вам, что нужно нажать кнопку Action,

маршрутизатор juniper srx210-2

В ней вы так же обнаружите команду Commit,

маршрутизатор juniper srx210-3

Теперь, допустим мне нужно настроить провайдерский канал, у меня есть сетевые настройки от него, и я хочу их настроить на сетевом интерфейсе fe-0/0/2, он 100 мб, мне больше и не нужно. Выбираем fe-0/0/2 и жмем Add > Logical interface, чтобы создать новый логический интерфейс.

Как настроить сетевой интерфейс на маршрутизаторе juniper srx210-4

Указываем unit 0, это номер лог интерфейса, задаем зону, у нас это будет Untrust, если вы ее еще не создали пропустите этот пункт, ниже покажу как это сделать. Жмем кнопку Add и задаем статический ip адрес.

Как настроить сетевой интерфейс на маршрутизаторе juniper srx210-5

Все интерфейс готов, если у вас еще нет зоны untrust, команду выше я давал, но все можно сделать и через веб, раздел Security > Zone/Screens, нажимаем Add

Как настроить сетевой интерфейс на маршрутизаторе juniper srx210-7

Пишем имя зоны, ее описание тип ставим security, ниже добавляем интерфейсы.

Как настроить сетевой интерфейс на маршрутизаторе juniper srx210-8

На вкладке Host inbound traffic - Zone можно добавить какие службы будут доступны в этой зоне, я для проверки поставил ping.

Как настроить сетевой интерфейс на маршрутизаторе juniper srx210-10

Теперь давайте пропишем для нашего маршрутизатора Juniper, шлюз выданный провайдером. Заходим в меню Routing > Static routing. Жмем Add в вверху пишем 0.0.0.0 subnet mask 0.0.0.0 в поле Next hop жмем Add и задаем тут шлюз выданный провайдером, не забываем сохранить.

Настройка шлюза Juniper

Все сохраняем, по сути перед вами будет все та же таблица маршрутизации, тут вы будите например добавлять статические маршруты.

Как видите, настройка не очень сложная и занимает минут 5-7, при наличии всех данных для заполнения.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

я в гугл